Revel Systems Status

Core Reporting XT degraded performance
Incident Report for Revel Systems
Resolved
This incident has been resolved.
Posted Apr 10, 2023 - 14:12 UTC
Monitoring
A fix has been implemented and we are now monitoring the situation.
Posted Apr 10, 2023 - 13:50 UTC
Investigating
We are currently investigating this issue.
Posted Apr 10, 2023 - 13:25 UTC
This incident affected: Core Reporting XT.