Revel Systems Status

Core product services slow/unresponsive
Incident Report for Revel Systems
Resolved
This incident has been resolved.
Posted Mar 30, 2023 - 22:22 UTC
Update
We are continuing to work on a fix for this issue.
Posted Mar 30, 2023 - 19:52 UTC
Identified
The issue has been identified and a fix is being implemented. For the time being to continue being operational please follow this guide to enable Offline Mode. https://support.revelsystems.com/s/article/Manual-Offline-Mode-on-the-Point-of-Sale-1582898972014
Posted Mar 30, 2023 - 18:16 UTC
Investigating
We are currently investigating this issue.
Posted Mar 30, 2023 - 18:05 UTC
This incident affected: Management Console (Core Services).