Revel Status

Telephony issues

Incident Report for Revel Systems

Resolved

The incident has been resolved, and all functionality has been restored.
Posted Jun 26, 2025 - 16:15 UTC

Identified

The cause of the issue has been identified, and we are working on a solution.
In the meantime, please use this phone number to reach out to our customer service teams: +1 (484) 960-3416
Posted Jun 26, 2025 - 14:17 UTC

Investigating

Currently, our telephony system is experiencing issues, and the phone lines are not available.
Please reach out via email: support@revelsystems.com in the meantime.
Or chat via: https://support.revelsystems.com/s/

We will update you once it is fixed.
Posted Jun 26, 2025 - 14:06 UTC
This incident affected: Customer Support.