Revel Status

Loyalty outage

Incident Report for Revel Systems

Resolved

Cloudflare outage has been resolved.
Systems are fully operational
Posted Jun 12, 2025 - 21:33 UTC

Investigating

Loyalty is affected by the Cloudflare outage.
Cloudflare teams are working on fixing.
Our teams are monitoring and will update once the outage is resolved
Posted Jun 12, 2025 - 19:41 UTC
This incident affected: Gift integrations (Paytronix, Givex) and Loyalty integrations (Como, Paytronix).