Revel Systems Status

Chat functionality is currently not working
Incident Report for Revel Systems
Resolved
The issue has been resolved. The chat functionality is up and running.
Posted Mar 20, 2023 - 19:58 UTC
Investigating
The chat functionality is currently not available. If you do have any inquiries please feel free to reach out to support by phone.
https://support.revelsystems.com/s/article/Call-Support-1582893041274
Posted Mar 20, 2023 - 18:17 UTC