Revel Systems Status

Paytronix Loyalty degraded performance
Incident Report for Revel Systems
Resolved
This incident has been resolved.
Posted Feb 14, 2023 - 19:24 UTC
Monitoring
Paytronix is reporting degraded performance for Paytronix Loyalty.
The issue has been identified and a fix is implemented.
All services are expected to be returning to normal.
Paytronix will continue to monitor performance closely to ensure that everything is working as it should be.
Posted Feb 14, 2023 - 18:41 UTC
This incident affected: Loyalty integrations (Paytronix).