Revel Systems Status

Management Console connectivity issues due to a Third Party Outage
Incident Report for Revel Systems
Resolved
This incident has been resolved.
Posted Mar 06, 2024 - 00:47 UTC
Monitoring
The issue has been resolved. We are continuing to monitor
Posted Mar 05, 2024 - 22:06 UTC
Identified
Comcast users in California might face difficulties reaching the Management Console. The issue is being investigated.
Posted Mar 05, 2024 - 21:27 UTC
This incident affected: Management Console (Core Services).