Revel Systems Status

Telephony service disruption
Incident Report for Revel Systems
Resolved
The telephony issue outage has just been resolved. Telephony systems are operational again.
Posted Dec 21, 2023 - 14:22 UTC
Update
Currently, we are still actively investigating the issue.
Posted Dec 21, 2023 - 14:03 UTC
Investigating
We are currently investigating the Telephony issue outage. If you cannot reach support via our general support phone number, please submit a ticket via support@revelsystems.com.
Posted Dec 21, 2023 - 13:34 UTC
This incident affected: Customer Support.