Revel Systems Status

Freedompay transaction latency on Freeway platform
Incident Report for Revel Systems
Resolved
FreedomPay has resolved the transaction processing latency issues and all transaction processing has returned to normal. Please follow this guide to process offline/decdlined transactions: https://support.revelsystems.com/s/article/How-to-Manually-Batch-Uncaptured-Offline-and-or-Declined-Credit-Card-Transactions-1582901172686
Posted Mar 27, 2023 - 18:37 UTC
Update
FreedomPay's Technical Team is continuing to investigate possible latency in transactions. We will continue to update the status of this page as updates become available. We recommend turning on offline payment processing on the POS: https://support.revelsystems.com/s/article/Manual-Offline-Mode-on-the-Point-of-Sale-1582898972014
Posted Mar 27, 2023 - 17:23 UTC
Investigating
FreedomPay is currently investigating reports of transaction processing latency with Freeway, FreedomPay's payment gateway. FreedomPay's Incident Response team is currently investigating the incident and will provide additional updates as soon as they arise.
Posted Mar 27, 2023 - 16:37 UTC
This incident affected: Payments Processing (FreedomPay).